Commit 6db03623 authored by Till Brehm's avatar Till Brehm

Fixed a Bug in Centos 7 were php-fpm uses sockets while mod_proxy_fcgi in...

Fixed a Bug in Centos 7 were php-fpm uses sockets while mod_proxy_fcgi in centos 7 does not support that yet.
parent 8348c814
......@@ -2664,7 +2664,8 @@ class apache2_plugin {
$tpl->newTemplate('php_fpm_pool.conf.master');
$tpl->setVar('apache_version', $app->system->getapacheversion());
if($data['new']['php_fpm_use_socket'] == 'y'){
// Use sockets, but not with apache 2.4 on centos (mod_proxy_fcgi) as socket support is buggy in that version
if($data['new']['php_fpm_use_socket'] == 'y' && in_array('fastcgi_module',$apache_modules)){
$use_tcp = 0;
$use_socket = 1;
if(!is_dir($socket_dir)) $app->system->mkdirpath($socket_dir);
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment