Commit 7d8d3735 authored by Till Brehm's avatar Till Brehm

Limit patch requieremnt to servers with amavisd-new

parent 5e43b353
......@@ -97,7 +97,8 @@ require_once 'lib/classes/tpl.inc.php';
die('We will stop here. There is already a ISPConfig installation, use the update script to update this installation.');
}*/
if(!is_installed('patch')) die('The patch command is missing. Install patch command and start installation again.');
// Patch is required to reapir latest amavis versions
if(is_installed('amavisd-new') && !is_installed('patch')) die('The patch command is missing. Install patch command and start installation again.');
//** Get distribution identifier
$dist = get_distname();
......
......@@ -98,7 +98,8 @@ if(is_dir('/root/ispconfig') || is_dir('/home/admispconfig')) {
die('This software cannot be installed on a server wich runs ISPConfig 2.x.');
}
if(!is_installed('patch')) die('The patch command is missing. Install patch command and start installation again.');
// Patch is required to reapir latest amavis versions
if(is_installed('amavisd-new') && !is_installed('patch')) die('The patch command is missing. Install patch command and start update again.');
//** Get distribution identifier
$dist = get_distname();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment