Commit f9318304 authored by tbrehm's avatar tbrehm
Browse files

- Added version check to autoupdate script.

- Added some default values for nginx in the web_domain_update function of the remote api.
- Fixed a php warning in the updater.
parent c2a1c72d
......@@ -79,6 +79,10 @@ unset($conf);
if($dist['id'] == '') die('Linux distribution or version not recognized.');
//** Check version
if(compare_ispconfig_version('3.0.3',ISPC_APP_VERSION) < 0) die("This updater is for ISPConfig versions > 3.0.3.0. Please Update to ISPConfig 3.0.3.3 first before you update to the current ISPConfig version.\n");
//** Include the distribution-specific installer class library and configuration
if(is_file('dist/lib/'.$dist['baseid'].'.lib.php')) include_once('dist/lib/'.$dist['baseid'].'.lib.php');
include_once('dist/lib/'.$dist['id'].'.lib.php');
......
......@@ -79,7 +79,7 @@ unset($conf);
if($dist['id'] == '') die('Linux distribution or version not recognized.');
//** Check version
if(compare_ispconfig_version('3.0.3',ISPC_APP_VERSION) < 0) die('This updater is for ISPConfig versions > 3.0.3.0. Please Update to ISPConfig 3.0.3.3 first before you update to the current ISPConfig version.');
if(compare_ispconfig_version('3.0.3',ISPC_APP_VERSION) < 0) die("This updater is for ISPConfig versions > 3.0.3.0. Please Update to ISPConfig 3.0.3.3 first before you update to the current ISPConfig version.\n");
//** Include the distribution-specific installer class library and configuration
if(is_file('dist/lib/'.$dist['baseid'].'.lib.php')) include_once('dist/lib/'.$dist['baseid'].'.lib.php');
......
......@@ -1372,6 +1372,13 @@ class remoting {
$this->server->fault('permission_denied', 'You do not have the permissions to access this function.');
return false;
}
//* Set a few defaults for nginx servers
if($params['pm_max_children'] == '') $params['pm_max_children'] = 1;
if($params['pm_start_servers'] == '') $params['pm_start_servers'] = 1;
if($params['pm_min_spare_servers'] == '') $params['pm_min_spare_servers'] = 1;
if($params['pm_max_spare_servers'] == '') $params['pm_max_spare_servers'] = 1;
$affected_rows = $this->updateQuery('../sites/form/web_domain.tform.php',$client_id,$primary_id,$params);
return $affected_rows;
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment