Commit daf71a39 authored by tbrehm's avatar tbrehm
Browse files

Fixed: FS#1330 - Bug in ssl part of vhost config when suphp is used.

parent 01d133cd
...@@ -305,6 +305,10 @@ ...@@ -305,6 +305,10 @@
# suexec enabled # suexec enabled
SuexecUserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'> SuexecUserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
</tmpl_if> </tmpl_if>
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
<tmpl_if name='php' op='==' value='mod'> <tmpl_if name='php' op='==' value='mod'>
# mod_php enabled # mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5 AddType application/x-httpd-php .php .php3 .php4 .php5
...@@ -317,13 +321,18 @@ ...@@ -317,13 +321,18 @@
</tmpl_if> </tmpl_if>
</tmpl_if> </tmpl_if>
<tmpl_if name='php' op='==' value='suphp'> <tmpl_if name='php' op='==' value='suphp'>
suPHP_Engine on # suphp enabled
# suPHP_UserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'> <Directory {tmpl_var name='web_document_root'}>
<IfModule mod_suphp.c>
suPHP_Engine on
# suPHP_UserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
<tmpl_if name='has_custom_php_ini'> <tmpl_if name='has_custom_php_ini'>
suPHP_ConfigPath <tmpl_var name='custom_php_ini_dir'> suPHP_ConfigPath <tmpl_var name='custom_php_ini_dir'>
</tmpl_if> </tmpl_if>
AddHandler x-httpd-suphp .php .php3 .php4 .php5 AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp suPHP_AddHandler x-httpd-suphp
</IfModule>
</Directory>
</tmpl_if> </tmpl_if>
<tmpl_if name='php' op='==' value='cgi'> <tmpl_if name='php' op='==' value='cgi'>
# php as cgi enabled # php as cgi enabled
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment