Commit 225e1581 authored by Marius Burkard's avatar Marius Burkard
Browse files

Merge branch...

Merge branch '6311-add-warning-to-update-script-when-incorrect-php-version-is-used-as-default' into 'develop'

Resolve "Add warning to update script when incorrect PHP version is used as default"

Closes #6311

See merge request !1589
parents 62204fa9 d31c4af6
......@@ -249,6 +249,7 @@ class installer_base {
$msg = '';
if(version_compare(phpversion(), '5.4', '<')) $msg .= "PHP Version 5.4 or newer is required. The currently used PHP version is ".phpversion().".\n";
if(version_compare(phpversion(), '8.0', '>=')) $msg .= "PHP Version 8 is not supported yet. Change PHP version back to the default version of the OS. The currently used PHP version is ".phpversion().".\n";
if(!function_exists('curl_init')) $msg .= "PHP Curl Module is missing.\n";
if(!function_exists('mysqli_connect')) $msg .= "PHP MySQLi Module is nmissing.\n";
if(!function_exists('mb_detect_encoding')) $msg .= "PHP Multibyte Module (MB) is missing.\n";
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment