Commit ab4939d9 authored by Marius Cramer's avatar Marius Cramer

Fixed: FS#3042 - APS installer invalid ID error with Joomla

 patch from: http://www.howtoforge.com/forums/showthread.php?t=62788&page=2
parent f9c424db
......@@ -155,6 +155,7 @@ class ApsGUIController extends ApsBase
CONCAT(version, '-', CAST(`release` AS CHAR)) AS current_version
FROM aps_packages
WHERE name = (SELECT name FROM aps_packages WHERE id = ".$app->db->quote($id).")
AND package_status = 2
ORDER BY REPLACE(version, '.', '')+0 DESC, `release` DESC");
if(!empty($result) && ($id != $result['id'])) return $result['id'];
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment